Continental 816R-3C IPA

FM does it with frequency!
Post Reply
mnow
Posts: 1
Joined: Tue Oct 10, 2017 2:22 am

Continental 816R-3C IPA

Post by mnow » Tue Oct 10, 2017 3:35 am

Got an 816R with a Delta RF Technology 700w IPA that won't go past 340 watts.
Exciter is working good, but anything past 12 watts input to the IPA does not produce any more output.
Possibly a power limit from the power supply?
Can not find any info for the power supply from Continental.
Has anyone else seen this issue?

User avatar
Dale H. Cook
Posts: 770
Joined: Thu Dec 20, 2007 9:08 am
Location: Roanoke/Lynchburg, VA
Contact:

Re: Continental 816R-3C IPA

Post by Dale H. Cook » Tue Oct 10, 2017 5:55 am

Have you looked at the load on the IPA with a wattmeter? Solid state IPAs (and solid state transmitters) are generally unforgiving of a load that isn't close to 50+j0. It would also be a good idea to see how it plays into a dummy load.
Dale H. Cook, Contract Engineer, Roanoke/Lynchburg, VA
http://plymouthcolony.net/starcityeng/index.html

Lee_Wheeler
Posts: 82
Joined: Sun Jul 24, 2016 1:53 pm
Location: Kansas City

Re: Continental 816R-3C IPA

Post by Lee_Wheeler » Tue Oct 10, 2017 5:09 pm

I have a pair of them (816-R3s) combined that had the MMD versions, one of them croaked earlier this year and Continental has basically disavowed any support for them beyond selling a new version. If the supply voltage isn't sagging below normal then chances are the amplifier itself is at fault.

The Delta amplifiers are now serviced by SVPA. Some are still serviceable and some are not due to the availability of the Mosfets. The guy to talk to is Sarkis Kazarian. You have to jump through a bunch of hoops to get them serviced but Sarkis will be able to tell you if he can repair them based on the model number. I think the website is still under Delta RF.

For the MMD amps I wound up buying a pair of new drop in replacements from a company called American Amplifier Technologies. They were physically identical to the MMD amps that they replaced and the swap was a total breeze. They use the new LDMOS devices so they are fairly state of the art. It has been under a year but they have behaved flawlessly. I think they were around $1700 each which was a far cry less than the Continental replacements. They may have similar drop in replacements for the Delta amplifiers.

...Lee

TPT
Posts: 679
Joined: Mon Dec 03, 2007 3:18 pm
Location: St. Marys, WV

Re: Continental 816R-3C IPA

Post by TPT » Wed Oct 11, 2017 8:22 am

Has almost a year turnaround by Silicon Valley Amplifier on a repair of a similar type of IPA amp for a Harris HT transmitter. Unless you have a spare, may be more cost-effective just to upgrade the IPA.

User avatar
davek
Posts: 164
Joined: Sun Aug 02, 2009 7:28 pm
Location: Sydney, Australia

Re: Continental 816R-3C IPA

Post by davek » Wed Oct 11, 2017 10:59 pm

Another option for to consider: I have seen on Mark Persons' website the work he does to replace failed IPA boards with modules from Broadcast Concepts.

For example...
http://www.mwpersons.com/tech-tips/FM/C ... 5A-ipa.htm

BigRed
Posts: 92
Joined: Tue Mar 27, 2012 8:59 am

Re: Continental 816R-3C IPA

Post by BigRed » Thu Oct 12, 2017 6:05 pm

The company that Mr. Pearson's WEB site refers to, Broadcast Concepts, also offers a repair service on those amplifiers. The price of $450 is pretty good too given that they replace both transistors, which are over $100 each.

http://broadcastconcepts.com/700W-SVPA.html

They also have several 700-watt amplifers available on this WEB page:

http://broadcastconcepts.com/27/


If you want to try your hand at fixing the amplifier yourself you might run into issues finding the MRF-151 transistors. They seem to be pretty tough to come by these days, apparently discontinued by M/A-Comm. But there is a substitute. The SD2942W should be a drop-in replacement. And I don't believe that this particular amplifier has any tuning handles, and only a bias control for each transistor, which should be set "close enough" from the old transistor. A word of caution though. The last one of these amps that I was inside of had other issues, mainly a burnt-up terminal strip to the outside world.

BigRed
Posts: 92
Joined: Tue Mar 27, 2012 8:59 am

Re: Continental 816R-3C IPA

Post by BigRed » Thu Oct 12, 2017 6:20 pm

Dale H. Cook wrote:
Tue Oct 10, 2017 5:55 am
Have you looked at the load on the IPA with a wattmeter? Solid state IPAs (and solid state transmitters) are generally unforgiving of a load that isn't close to 50+j0. It would also be a good idea to see how it plays into a dummy load.
And that dummy load test of the existing amplifier . . EXCELLENT idea before you jump into the deep end of the pool.

User avatar
Dale H. Cook
Posts: 770
Joined: Thu Dec 20, 2007 9:08 am
Location: Roanoke/Lynchburg, VA
Contact:

Re: Continental 816R-3C IPA

Post by Dale H. Cook » Thu Oct 12, 2017 6:45 pm

BigRed wrote:
Thu Oct 12, 2017 6:20 pm
And that dummy load test of the existing amplifier . . EXCELLENT idea before you jump into the deep end of the pool.
It seemed to me that the OP may have been assuming that the brick was bad, instead of troubleshooting the problem. In the nearly 50 years that I have been in broadcast engineering I have made mistaken assumptions about a problem too many times.
Dale H. Cook, Contract Engineer, Roanoke/Lynchburg, VA
http://plymouthcolony.net/starcityeng/index.html

User avatar
Deep Thought
Posts: 3211
Joined: Thu Mar 20, 2008 9:23 am
Location: La Grange, IL
Contact:

Re: Continental 816R-3C IPA

Post by Deep Thought » Thu Oct 12, 2017 7:37 pm

Dale H. Cook wrote:
Thu Oct 12, 2017 6:45 pm
In the nearly 50 years that I have been in broadcast engineering I have made mistaken assumptions about a problem too many times.
I may or may not have spent the better part of two hours troubleshooting an intermittent ATU network one night only to find out a bug had crawled into an arc gap and lowered the 'trip point' by about 50%. 8)
Mark Mueller • Mueller Broadcast Design • La Grange, IL • http://www.muellerbroadcastdesign.com

User avatar
NECRAT
Site Admin
Posts: 2950
Joined: Sat Nov 17, 2007 9:13 pm
Location: Taunton, MA
Contact:

Re: Continental 816R-3C IPA

Post by NECRAT » Thu Oct 12, 2017 8:08 pm

Dale H. Cook wrote:
Thu Oct 12, 2017 6:45 pm
BigRed wrote:
Thu Oct 12, 2017 6:20 pm
And that dummy load test of the existing amplifier . . EXCELLENT idea before you jump into the deep end of the pool.
It seemed to me that the OP may have been assuming that the brick was bad, instead of troubleshooting the problem. In the nearly 50 years that I have been in broadcast engineering I have made mistaken assumptions about a problem too many times.
It's in our nature as engineers to do that. Quickly. Couldn't get the TV to turn on in my folks guest room. Power cycled the TV, checked the plug strip, etc. Of course, maybe the first thing I could've checked was if the remote control had batteries or not. Somehow bypassed the obvious.
http://www.necrat.us

"Arguing with an engineer is like mud wrestling with a pig. After a couple of hours, you realize the pig likes it"

Post Reply