Search found 11 matches

by engnewbie
Wed Mar 04, 2020 9:21 pm
Forum: Ask the Engineers
Topic: Is my Rate too high or is the owner high?
Replies: 13
Views: 566

Re: Is my Rate too high or is the owner high?

Dale and Kevin,

Thanks for taking time to respond. It is very helpful to hear what other engineers charge and the pay structures they use. I am now thinking maybe the retainer isn't worth it for the expectations it brings.
by engnewbie
Tue Mar 03, 2020 9:49 pm
Forum: Ask the Engineers
Topic: Is my Rate too high or is the owner high?
Replies: 13
Views: 566

Re: Is my Rate too high or is the owner high?

Thank you for the valuable response. Based on your comments, I don't think I am overcharging. If I have to cut my rate, I usually just walk away, but since this was a bit more (with travel) than I usually charge I thought maybe I've just gotten greedy.

I greatly appreciate your time.
by engnewbie
Tue Mar 03, 2020 7:05 pm
Forum: Ask the Engineers
Topic: Is my Rate too high or is the owner high?
Replies: 13
Views: 566

Is my Rate too high or is the owner high?

I have been working as a contract engineer for some stations in my state for about 5 years with a $120 retainer and a $120 site visit fee. I was asked to take over chief duties at a station in another state and 2.5 hours one way. The station is in an isolated part of the state and no engineers live ...
by engnewbie
Sat Jun 08, 2019 8:00 pm
Forum: AM Radio
Topic: SX 2.5 Won't Power on No Lights
Replies: 10
Views: 610

Re: SX 2.5 Won't Power on No Lights

KPJL FM wrote:
Thu Jun 06, 2019 7:05 am
Loose bolts are one thing, but a guy should never have loose nuts.
:lol:
by engnewbie
Wed Jun 05, 2019 9:22 pm
Forum: AM Radio
Topic: SX 2.5 Won't Power on No Lights
Replies: 10
Views: 610

SX 2.5 Won't Power on No Lights

My SX 2.5 did not wake up this morning. in fact, it was stone cold when I arrived. I had no +5 or +/- 15 volts. I found 120 volts on one AC leg feeding the step-start contactor but not on the other leg. I traced the problem to a chard terminal on the AC terminal strip located under the transmitter f...
by engnewbie
Wed Jun 05, 2019 9:07 pm
Forum: AM Radio
Topic: Gates One Blows PA Fuses w/ Modulation
Replies: 31
Views: 2960

Re: Gates One Blows PA Fuses w/ Modulation

Thanks. I guess those FETs don't like to lose power when operating.
by engnewbie
Tue Jun 04, 2019 9:29 pm
Forum: AM Radio
Topic: Gates One Blows PA Fuses w/ Modulation
Replies: 31
Views: 2960

Re: Gates One Blows PA Fuses w/ Modulation SOLVED

Boy, do I feel silly. After months of replacing FETs and blown fuses, I found the problem. But first, a bit more background. One day the manager called me and said the transmitter power was down to 800 watts with no blown fuse indicators, so I scheduled a visit the next day. When I arrived, he told ...
by engnewbie
Tue Jan 01, 2019 12:39 pm
Forum: AM Radio
Topic: Gates One Blows PA Fuses w/ Modulation
Replies: 31
Views: 2960

Re: Gates One Blows PA Fuses w/ Modulation

Thanks, again, Dale. I appreciate it.
by engnewbie
Tue Jan 01, 2019 12:10 pm
Forum: AM Radio
Topic: Gates One Blows PA Fuses w/ Modulation
Replies: 31
Views: 2960

Re: Gates One Blows PA Fuses w/ Modulation

Thanks, Dale. Interesting you mentioned that, as I had just read the 5 inch-pounds spec from the manual when replacing the MOSFETS.

Does a fluke 87 have enough voltage to turn on the MOSFETS when testing? It has a 9V battery.

Thanks.
by engnewbie
Tue Jan 01, 2019 2:36 am
Forum: AM Radio
Topic: Gates One Blows PA Fuses w/ Modulation
Replies: 31
Views: 2960

Re: Gates One Blows PA Fuses w/ Modulation

Thanks, guys. I appreciate your fast response and insights. I also maintain an SX 2.5 and MUCH prefer the cleaner design of the Gates One. Looks like I'll be checking MOSFETS. No, the two associated MOSFETS are about the only ones that have NOT been replaced, from appearances. Gates Air has TO-3s fo...
by engnewbie
Mon Dec 31, 2018 8:02 pm
Forum: AM Radio
Topic: Gates One Blows PA Fuses w/ Modulation
Replies: 31
Views: 2960

Gates One Blows PA Fuses w/ Modulation

I have a Gates One that blows PA F21 (always F21 and no other) with high modulation. Up to about 85%, all is good. Above 85% and the fuse indicator starts to blink. Around 90% and above, the fuse pops--sometimes at lower modulation levels. I changed from 3A to 4A (per bulletin) but to no avail. Am I...