Repair Log: BE FXi-60

FM does it with frequency!
Post Reply
User avatar
davek
Posts: 176
Joined: Sun Aug 02, 2009 7:28 pm
Location: Sydney, Australia

Repair Log: BE FXi-60

Post by davek » Mon Jan 15, 2018 1:03 pm

Hello everyone, and Happy New Year!

This is a quick repair log of a Broadcast Electronics FXi-60 exciter. It has been in continuous service for a little over 10 years before developing it's first fault - when it went from working just fine to totally dead.

When it ended up on my bench, I removed the side of the chassis containing the power supply (as I suspect that's where the fault was). Also,kudos to BE for designing the power supply to be easy to remove and test in-situ, and for supplying full schematics in the manual!

Both main AC fuses (F1, F2) were okay, as was the AC fuse (F3) for the auxiliary power supply transformer. Fuse F8 was found to be open, which is on the secondary side of the auxiliary power supply transformer. It wasn't violently blown but had gently melted away.

The auxiliary power supply provides voltage for all the control circuits of the main power supply, and consists of a MOSFET pre-regulator (Q26), a 12V regulator (U6) and a 21.5V regulator (U27). Some quick probing with the multimeter revealed a dead-short between the 12V rail (TP4) and GND (TP8).

The 12V regulator is a LM2576HVT-12 switch-mode regulator, requiring only an external diode, inductor, and 2 capacitors. I removed the regulator and it's associated diode (D24) and got lucky - the diode tested short-circuit.

After removing it there was no longer a short anywhere on the 12V rail, and all the other major semiconductors tested okay, so I rigged up and external 12V power source and applied mains power. Some relays clicked, power LED came on, LCD screen came to life and the fan started whirring.

I can't find a solid explanation for why the diode failed, but after 10 years of continuous service I figured it chose to retire on it's own terms. :lol:

Both D24 and U6 were replaced to complete the repairs. In the end it was a simple repair but I figure it might be useful information to share.. thanks for reading.

Some photos:
IMG_3097.JPG
Failed parts...
 
IMG_3096.JPG
PSU running on external 12V supply
 
IMG_3098.JPG
Working again

kcbooboo
Posts: 492
Joined: Sat Dec 10, 2011 4:53 pm
Location: East of the Mississippi

Re: Repair Log: BE FXi-60

Post by kcbooboo » Tue Jan 16, 2018 6:31 am

The snubber diode in a switching PS does almost as much work as the driver transistor. There's a lot of peaky inductive energy sent into it. Those two parts are getting quite a workout. They just might have gotten tired. It happens. Be glad you got 10 fault-free years.

Good repair, though.

Bob M.

Kelly
Posts: 489
Joined: Thu Aug 21, 2008 5:32 pm
Location: Washington D.C. Area

Re: Repair Log: BE FXi-60

Post by Kelly » Thu Jan 18, 2018 7:45 pm

The FXi-60 is one of the best sounding exciters, ever.
Skype:kellyalford Twitter: @KellyAlford

W2XJ
Posts: 109
Joined: Mon Dec 03, 2007 12:15 pm

Re: Repair Log: BE FXi-60

Post by W2XJ » Mon Jan 22, 2018 5:28 pm

Maybe ‘ever’ for an analog exciter although we preferred the FX50.

Kent T
Posts: 112
Joined: Mon Dec 17, 2012 7:29 pm

Re: Repair Log: BE FXi-60

Post by Kent T » Tue May 01, 2018 9:17 am

And let us also not forget the FX-30, these BE exciters are "The Audiophile Exciter" only Collins and Continental matched them for audio quality.

Post Reply